XANO auth - social login updated today. BREAKS DEFAULT CONFIGURATION

Hello :wave:

The XANO auth plugin was updated today, but unfortunately, it broke the default implementation of user/pass authentication!

At this point I have to setup Social login in the Xano auth plugin to get the ‘Login’ action to work. This is a problem for me, and anyone else who isn’t setting up social auth’s.

Everything was working fine until the update today. Now when I click on the Xano Login action the default configuration fields of email/pass no longer display. A yellow alert shows at the bottom of the screen saying the plugin needs configuration.

The plugin configuration still has my endpoints, but a new ‘social login’ config item appears. I have no intention of using social logins so I don’t want to spend an hour or more setting up an extension on XANO, configuring a project in google (for instance), and then setting up WeWEb when I have no intention of using social Auths.

The login action is completely broken right now - which is pretty frustrating! Can someone take a look and figure out how to make it an option in the plugin and not a requirement?

Thank you!

I can confirm that on my end the social login did not appear as required. It works without it being configured at all.

With regards to the issue that you mentioned, I did have the same one and was able to fix it by going through the configuration steps again (adding the API key from Xano, etc.). And then I could see the fields on the login component again.

This is was probably not an outcome the team expected after adding the social login options… Not sure what happened and if this reconfiguration can be prevented.

Hi everyone,

Sorry for the confusion. Don’t worry, your plugin is still working, and you do not need to setup social login.

We updated the auth plugin to make it as dynamic as the collection plugin. You now have to put your api key in the configuration and select your instance. Then we will parse it and provide you the list of your endpoints. You will be able to select your /me /login /signup endpoint from the list and that’s all, you will be done with the configuration.

Why we did that ? To implement social login but also to make possible to have dynamic parameters for your login and signup request. No more enforced email/password.

But your old configuration is still working in production, you just can’t edit it until you finished to configure the first step of your xano auth plugin.


If anyone else runs into this problem and are still confused… even though your XANO auth configuration settings show up as filled in, you need to click on the Configuration area and start over with adding your API key and then choosing the proper instance, workspace, GetMe, Login and SignUp endpoints. If you don’t do this, the ‘Login’ action will not display the ‘email’, and ‘password’ fields.

I’m not sure how this change impacts live sites (mine is still under development), but I’d like to see better documentation in the future for ‘breaking’ changes like this, and advance notice of any changes we need to make to avoid issues. Thanks.

1 Like

I have tried this but when setup up a new app and selecting my instance and workspace my dropdowns for xano auth/me, signup, and login don’t show any options even thought they are there.

Hi, we found out it can happen if you disabled the swagger for one of your api group. A fix should be deployed next week.

1 Like