Keep getting Axios errors & Image upload function randomly stopped working (bypass WeWeb CDN method)

Hi everyone, this is my first post here, if someone could help me diagnose / understand what happened here, I’d really appreciate it.

Sorry in advanced for the slightly long winded post, It’s important I provide the full context otherwise I don’t think anyone will be able to help.

Since I’m a new user in this forum, it will only let me embed one piece of media in a post, so I had to put the context and my question in this linked PDF (I hope this is ok mods, I have no other way of describing my issue).

**The nonPDF version below :point_down: **




Page 1 of 9


A few days ago, I followed the tutorial about uploading an image to WeWeb and sending it to

Xano while bypassing the WeWeb CDN - YouTube?


In the tutorial, there are two main workflow actions - first is the custom JavaScript action

(you can see the ‘succeeded’ green result for it below), then there is a second action where

you make a request to Xano and you pass in the previous actions result as an input for the

endpoint - this second action was returning me an axios error as you can see below.

(The two actions)

Page 1 of 9

Page 2 of 9

(Code for first action - custom JavaScript)

(Result for first action - custom JavaScript)

Page 2 of 9

Page 3 of 9

(formula binding for second action - ‘add image’ Xano request and its result)

The image above is just a replication of my steps, when I originally did it a few days ago, the

‘content’ field on the left and the ‘current value’ field in the formula, didn’t say ‘null’ - it read

‘content: Object’ (like below) and the ‘current value’ showed an object/data. However the

error message is the exact same one I received.

The workflow was working fine i.e my Xano database was getting populated with images etc.

As you can see above, I kept getting axios errors (isAxiosError: true) for the second action (the

request to Xano) when running this workflow, but since my Xano database was successfully

populating with images, I assumed the error message I was getting was benign.

The workflow continued to run successfully (images added to Xano) then all of sudden,

without changing anything, things stopped working.

So my Xano database is no longer getting populated with images.

I start getting this weird result for the first action - the custom JavaScript action (at this point

I’m just testing this individual action). It says ‘data: null’, even though there is definitely a file

present in the file uploaders input.

(Bear in mind I’ve changed nothing, the code and everything else is untouched and I’m not

Page 3 of 9

Page 4 of 9

anywhere close to Xano’s API rate limit or anything.)

I kept getting this weird result for a while. Then I started trying different images to make sure

it wasn’t a corrupted image or anything, I strictly stuck to JPGs.

Then after a while of getting this weird ‘null’ result, I started getting actual errors/failures for

this action instead.

I message WeWeb support in the chat box on the homepage to find out if maybe the site is

under maintenance, then I log off.

-------------------------------------------------( Next day)

I comeback to WeWeb after 15 hours and get a response in the chat that the site wasn’t under

maintenance or anything.

Before I try and change anything, I just test the first action (the custom JS) again to see if it’s

still not working, but now again without changing anything, I get the success result below, so

it works again?

Page 4 of 9

Page 5 of 9

But here’s the strange part for me, I check my Xano database and all the ‘null’ and ‘failed’

attempts from like 15 hours ago, when I was running the custom JS action on it’s own -

starting from the UFC logo record, all the way to the last Techstars logo record - are now

present in the database, as if they were delayed? The records also show that they were

created at the time I originally tried to create them i.e run the upload action.

So I was confused and began to research stuff, eventually focusing in on the axios error

message and I come across this article about axios.

Page 5 of 9

Page 6 of 9

Another search -

------------------(End of context)


Main Question:

Ultimately I just want to understand why the action/workflow, randomly stopped working,

because file upload is the most key component of the app I want to build and I will have no

confidence in it, if that functionality is going to randomly cease to work.

Is Axios the reason the actions randomly stopped working? If so, what are my alternatives?

If its not Axios then what was the cause?

I checked my Xano API request metric on the dashboard to make sure I didn’t exceed the rate

limit and it definitely wasn’t that.

Is it a case where too many axios errors cause a timeout? Or are the articles about axios being

unreliable true?

Why were the database entries delayed and only showed up in Xano much later? Xano


Page 6 of 9

Page 7 of 9

Why was action 2 - my Xano request ‘Add image’, always returning errors? (even when the

workflow was working).

When things stopped working and I resorted to just testing action 1 - the custom JS upload

action, why was that returning different ‘failed’ results, first ‘null’ then eventually an error?

A separate question:

(Regarding the tutorial) Why is it necessary to have a custom JavaScript action that posts to

the Xano endpoint, to where that action alone populates the Xano database - but then

another action after, where you pass the result of the custom JS action into the same

endpoints input in a separate request to Xano? Isn’t that doing the same thing twice?

I was experimenting some time afterwards, messing around with the JavaScript and wanted it

so that the code would just return the actual inputted file and not communicate with the

Xano endpoint → then bind the result of that JS into the input of my Xano endpoint. So that

everything is done in one action.

It worked but I still got an error, whether I was following the tutorial (like far above) or doing

my own thing I kept getting errors regardless.

Page 7 of 9

Page 8 of 9

It was working (so my Xano database got populated) but this is the error result it also


After a few runs, this action also stopped working (populating my Xano database), again

without changing anything.

Since then, I’ve been trying two different sets of code for the JavaScript upload action.

They’ve been working i.e both populate my Xano database - but the ‘data’ field of the results

for the actions still show as ‘null’.

Page 8 of 9

Page 9 of 9

So overall I’m just confused, I just don’t want it to break on me again and need to understand

why it did in the first place.

Page 9 of 9

WEWEB Post PDF (1).pdf

Jared Gibb (


General Info




2 MB


23:48 17 Sept


23:56 17 Sept


Anyone with the link

Can View




No description

Download Permission

Viewers can download

Page 7 of 9 Page 8 of 9 Page 9 of 9


Hi @TAQL :wave:

First of all, thanks so much for putting all of that information together, it really helps a lot!

Unfortunately, we haven’t been able to identify anything that may have caused this issue on our side and didn’t receive any other similar reports as far as I’m aware :confused:

If it happens again, could you take a moment to record a video sharing your screen and report it here?

It also helps a lot if you can show the detailed response from Xano which is usually in response > data > message because sometimes there’s a bit of additional information in there that can hint at what’s going on.

Here’s an example from a failed login attempt:

Hi Joyce, thanks for the response, will bear that in mind moving forward.

Just a few questions -

Is there a way I can send a file from WeWeb straight to my own CDN or Cloud storage and receive the files URL back in WeWeb? (so I can pass the URL along with other data attached to the user, to Xano) - this would be ideal.

If I was to just use the WeWeb CDN for now, what is my personal storage limit as a WeWeb user? What is the individual file-size limit for a single upload? and will I be eventually able to delete the files I’ve uploaded to your CDN and migrate them to my CDN?

Also is there rough idea on when a bespoke WeWeb element for this overall direct upload use-case will be available in the future? It’s such a key feature (not to sound patronising). PS - it would be awesome if it you could set max upload file sizes with it.

Hello @TAQL,

It’s possible to send a file from WeWeb straight to your CDN with the custom code action or our plugin REST API. You will need to use the endpoint of your CDN to upload the files. It should be approximately the same method as importing files directly to Xano

The personal storage of the WeWeb CDN depends on your plan:

  • 1Gb for Starter plan
  • 10Gb for Scale plan

For now, it’s only possible to upload files to the CDN of WeWeb. We don’t have any endpoints to manage these files (delete for example). You will need to do it manually in your editor

A new element for uploading directly to Xano should be available in October or November (we don’t know exactly when yet)


Awesome, thanks for your help Mael.

One final question is - with the new element for uploading directly to Xano, do you know if it will be just exclusive to Xano? or will it be open ended to where you can send files to other backends or CDNs using their endpoints?

For now, we are working for Xano specifically. But we want to have it for our other plugin (like Supabase) and other CDNs later. We don’t know when and for which yet, but it’s in our roadmap for sure

You can use our plugin REST API ton use their endpoints for now


Ok got it :grinning: thanks Mael