Linking to URL without "https://" opens back up to Weweb editor

Hello guys! Whenever I try to link an element in a collection list to it’s item.url, if the url does not contain “https://” it opens up into the weweb editor. Any suggestions?

I thought of a solution to append “https://” to the beginning, but if the user inputs the URL with the “Https://” already there then it will be double

Hi @neelsarode :wave:

Mmm this might be a quirk of the Editor. I’ll ask the tech team.

Does this happen when you publish your app in staging or production?

A possible workaround:

@Joyce getting the same issue too, at least in the editor.

Hi @nick :wave:

Does it work ok when you add the “https://” with a formula as shown above?

@Joyce yea, adding https it works fine.

I found in the editor that the “issue” also applies to workflows. Setting a workflow to open a page in a new tab does not.

@nick Have similar problem(s).
There is somewhere a problem with the editor/weweb.

Even my alert logic is not working all of the sudden anymore.

Hi @nick , @IKR, I’m not sure what you are referring to. Just checked on my side and the “Navigate to” workflow action works fine.

Can you each create a new community topic with details of your specific use case and screenshots of how things are setup so we can look into it further? If you can record a short video of what you are trying to achieve and what you have tried, even better! :grinning:

@Joyce Sorry, I had something set up wrong, so I deleted my previous message. User error.

Setting a workflow to open a page in a new tab still does not perform the action.

Ok, got it! Can you create a bug ticket if you haven’t already?

Yea, this is still having trouble in the editor. I’ll open a ticket.