Auth0 integration - Callback URL mismatch

I’ve integrated my project with Auth0. I’ve created a button for sign up / login with a workflow with an Auth0 action of “Login with Popup”. But when I click it I get Callback URL mismatch. on Auth0 popup.

Also when setting up Auth0 plugin I’m getting this error Unable to get plugin roles. Please verify the plugin configuration.

Hi @brunoconleite :wave:

It seems you are missing the Auth0 token in WeWeb:

Here’s where you can find it in Auth0:

Hello @Joyce. I’ve followed the tutorials and available videos. It was set up correctly:


I’ve also tried removing the plugin and adding it again from scratch but the issue persisted.

Mmm, I’m sorry to hear that :slightly_frowning_face:

The Auth0 plugin seems to be working fine on our side but we’ll investigate further. I’ll get back to you asap!

Thanks @Joyce, please let me know if you want to schedule some time so I can guide you through the issue.

Hi again @brunoconleite :wave:

I can confirm there are no issues with the Auth0 plugin at the moment.

Would you mind recording a short loom showing your setup in Auth0 and WeWeb, maybe walk us through how you setup the plugin from scratch so we can figure out what’s going on?

Feel free to send me the recording in a DM to keep your token safe :slight_smile:

Hello @Joyce. Couldn’t find a way to send a DM on this system.

On the mailbox screen is stated that you should click on user avatar and select the message button.
image
But I can’t see any message button on your avatar.

So I’m sharing the link to the video here directly. The token is being shown partially only.

I’ve splitted the post in multiple messages because the community system insists that I can only attach one media per post as I’m a new user.

So I’m sharing the link to the video here directly. The token is being shown partially only.

I’ve splitted the posts here in multiple messages because the community system insists that I can’t attach more than one media per post.

I’ve posted the video link here but the community bot is hiding it for your review. You may find the link there.

Here is the part from mailbox that wrongly instructs how to send DMs

Hi @brunoconleite, sorry you’ve been hitting all the walls! Thanks a lot for your patience and taking the time to record this video :slight_smile:

We’re looking it to it now.

Hi @brunoconleite, we’ve found the problem :slight_smile:

It was coming from the setup in Auth0.

The Machine-to-Machine application needs to have the rights to configure the Single Page Application.

In your case, you wanted to use the Satori API so you would need to toggle the “Unauthorized” setting here:

Then, you would need to select all the permissions so WeWeb can configure the SPA:

Does that help?

Thanks @Joyce. That worked! I can also see that the auth0 token is available on plugin.
I was able to call the API successfully.

Just a note: my auth0 API had an audience set up so I had to put this as the default audience on my tenant so that the Weweb tokens have this audience also.

1 Like