Avoid horizontal movement of scrollbar


When I am having an input field and get the scrollbar because the content is too big, I am getting this weird behaviour of the scrollbar that I can grow and shrink it to any size by dragging the bottom right corner.

This is great vertically, but doing this horizontally is just odd and is a weird experience to me.

My question is: How can I lock at least the horizontal movement?

Here is a video of the issue: https://www.loom.com/share/3fd874087846405dae75572e034c15e3?sid=c728e54e-6a4a-4b01-910e-0f2985e62e5e

Hi @LarsL :wave:

Apologies for the late reply! Just saw this.

So, I’m not 100% it’s the result you’re looking for but these are the style settings I have on my Long answer input:

  • Resize is on
  • Width is auto
  • Height is auto
  • Overflow is Unset (that’s the default input setting by default but thought I’d mention it in case it’s on Scroll in your case)

And here’s what it looks like:
CleanShot 2023-08-18 at 00.58.37

Does that help?

Hi, Unfortunately it doesn’t.

I want the width to be fixed, maybe turn the corner dragging part completely off, if it’s not possible to do it just horizontally.

Ah ok. I misunderstood your question then.

Not sure it’s possible to allow users to change the height but not the width. You can definitely turn off the corner dragging part completely though:

Would be great if we got that resize lock by axis.

For now I will turn it off.


You can lock it on only one axis via custom css at the bottom with

overflow-x: hidden
overflow-y: hidden

Will try that! Thanks!